A couple of problem…
 
Share:
Notifications
Clear all

[Solved] A couple of problems with my new B-Robot


95a3009d07908806b3a40331d9517e99?s=80&d=mm&r=g
(@oldmufflerman)
Member
Joined: 1 week ago
Posts: 5
Topic starter  

hello all, I have a couple of problems with my robot.
when its first turned on it makes a loud vibrating noise and won’t balance. after rocking/rolling it it manually around for a couple of minutes it suddenly self balances nicely and then also works great with the iphone app. If it’s knocked over the vibrating noise comes back again and won’t self balance again, why?
also the servo arm only rotates about 45 or 50 degrees in either directions of travel which is not enough to raise it back up. how can I increase it to 90 degrees which is where I think it should be?
Thank you in advance ever so much for your speedy reply to my request.
Much appreciated!


Quote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 6 years ago
Posts: 780
 

That noise could come from the motor not having enough torque. Than can be solved incresing the voltage (using a 12V source). But it is completely normal with the stepper motors. What servo do you have? The sg90?


ReplyQuote
95a3009d07908806b3a40331d9517e99?s=80&d=mm&r=g
(@oldmufflerman)
Member
Joined: 1 week ago
Posts: 5
Topic starter  

Spoiler
@robotn1 


okay I see how to boost The power, I’ll do that. 
yes, I have the MG90S servo. 
It doesn’t rotate 90 degrees, maybe only about 75? 
mid there a way to adjust the servo travel?

Thank you in advance ever so much for your speedy reply to my request.

Much appreciated! 

Okay, I see how to boost the power, I'll do that. 
Yes I have the MG 90S servo. It doesn't move 90 degrees, maybe only 75 or so. 
Is there a way to adjust the servo travel?

Thank you in advance ever so much for your speedy reply to my request.
Much appreciated! 

 


ReplyQuote
Share: