Share:
Notifications
Clear all

Inkscape PY does not work


c84cdd76fec662879982202daaf01bf8?s=80&d=mm&r=g
(@woitas)
Member Customer
Joined: 2 years ago
Posts: 7
Topic starter  

I think everything works, at least, i can move the motor with the serial console of arduino.

But when i start inkscape and want to go to the eggbot control it only pukes errors:

Traceback (most recent call last):
  File "eggbot.py", line 1406, in 
    e.affect()
  File "inkex.py", line 283, in affect
    self.effect()
  File "eggbot.py", line 318, in effect
    self.EggbotOpenSerial()
  File "eggbot.py", line 1299, in EggbotOpenSerial
    self.serialPort = self.getSerialPort()
  File "eggbot.py", line 1356, in getSerialPort
    for strComPort in eggbot_scan.findEiBotBoards():
  File "eggbot_scanwin32.py", line 6, in findEiBotBoards
    hKey = _winreg.OpenKey( hReg, r"SYSTEMCurrentControlSetEnumUSBVID_04D8&PID_FD92" )
WindowsError: [Error 2] Das System kann die angegebene Datei nicht finden

i deinstalled and reinstalled all available version of Inkscape and the extension in any given constellation. Allways with the same result

I changed the COM from 13 to 2

doesnt work.

What else can i do?


Quote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 5 years ago
Posts: 722
 

I think everything works, at least, i can move the motor with the serial console of arduino.

But when i start inkscape and want to go to the eggbot control it only pukes errors:

Traceback (most recent call last):
  File "eggbot.py", line 1406, in 
    e.affect()
  File "inkex.py", line 283, in affect
    self.effect()
  File "eggbot.py", line 318, in effect
    self.EggbotOpenSerial()
  File "eggbot.py", line 1299, in EggbotOpenSerial
    self.serialPort = self.getSerialPort()
  File "eggbot.py", line 1356, in getSerialPort
    for strComPort in eggbot_scan.findEiBotBoards():
  File "eggbot_scanwin32.py", line 6, in findEiBotBoards
    hKey = _winreg.OpenKey( hReg, r"SYSTEMCurrentControlSetEnumUSBVID_04D8&PID_FD92" )
WindowsError: [Error 2] Das System kann die angegebene Datei nicht finden

i deinstalled and reinstalled all available version of Inkscape and the extension in any given constellation. Allways with the same result

I changed the COM from 13 to 2

doesnt work.

What else can i do?

Check this thread: http://forums.jjrobots.com/showthread.php?tid=1199 (point 3: replacing the eggbot.py file)


ReplyQuote
c84cdd76fec662879982202daaf01bf8?s=80&d=mm&r=g
(@woitas)
Member Customer
Joined: 2 years ago
Posts: 7
Topic starter  

Check this thread: http://forums.jjrobots.com/showthread.php?tid=1199 (point 3: replacing the eggbot.py file)

now its:

Unable to find an Eggbot on any serial port. :(

is there a way to check all function without that inkscape?
And could I edit the COM Port into the config file?
Something strange thats happening during flashing is:

...Erzwinge Reset durch öffnen/schließen mit 1200 bps auf dem Port COM10
PORTS {COM1, COM10, } / {COM1, } => {}
PORTS {COM1, } / {COM1, COM9, } => {COM9, }
Found upload port: COM9
...
         Using Port                    : COM9
         Using Programmer              : avr109
         Overriding Baud Rate          : 57600

it seems it swaps COM Ports during flashing (going with the hardware change sound)
I also went through reinstalling the Leonardo, although i dont think theres the problem. no change.
I checked the serial monitor command and the stepper turns, but at the end i hear one motor still chirping, it seems to be the Pen Stepper. It only stops when i reset the leonardo


ReplyQuote
c84cdd76fec662879982202daaf01bf8?s=80&d=mm&r=g
(@woitas)
Member Customer
Joined: 2 years ago
Posts: 7
Topic starter  

I deinstalled. inkscape and deleted every eggbot file.
I deinstalled Arduino.
Reinstalled Arduino.
=> Leonardo found
=> Leonardo flashed: OK
=> SM,2000,0,-200: OK
=> chirping Stepper: Reset Leonardo: OK

then i got the 32bit Version of inkscape 0.91 (the zipped version) and put it in another folder.
i started it with Admin rights.: OK
quit Inkscape
i installed eggbot 2.4.0 from “eggbot_240.exe”
start inkscape
opened the now present EGGBOT Control.

Traceback (most recent call last):

  File "eggbot.py", line 1406, in 

    e.affect()

  File "D:toolsinkscapeshareextensionsinkex.py", line 268, in affect

    self.effect()

  File "eggbot.py", line 314, in effect

    self.EggbotOpenSerial()

  File "eggbot.py", line 1299, in EggbotOpenSerial

    self.serialPort = self.getSerialPort()

  File "eggbot.py", line 1356, in getSerialPort

    for strComPort in eggbot_scan.findEiBotBoards():

  File "D:toolsinkscapeshareextensionseggbot_scanwin32.py", line 6, in findEiBotBoards

    hKey = _winreg.OpenKey( hReg, r"SYSTEMCurrentControlSetEnumUSBVID_04D8&PID_FD92" )

WindowsError: [Error 2] Das System kann die angegebene Datei nicht finden

HMPF

quit Inkscape
replaced the eggbot.py
start inkscape|Eggbot control:

YAY! ok its now repsonding.

BUT: i still hear that motor humming after using the Pen Stepper. Is that normal
“disable Motors” turns it off.

OK, now i need to Home and callibrate it i guess …. i dont find a documentation


ReplyQuote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 5 years ago
Posts: 722
 

I deinstalled. inkscape and deleted every eggbot file.
I deinstalled Arduino.
Reinstalled Arduino.
=> Leonardo found
=> Leonardo flashed: OK
=> SM,2000,0,-200: OK
=> chirping Stepper: Reset Leonardo: OK

then i got the 32bit Version of inkscape 0.91 (the zipped version) and put it in another folder.
i started it with Admin rights.: OK
quit Inkscape
i installed eggbot 2.4.0 from “eggbot_240.exe”
start inkscape
opened the now present EGGBOT Control.

Traceback (most recent call last):

  File "eggbot.py", line 1406, in 

    e.affect()

  File "D:toolsinkscapeshareextensionsinkex.py", line 268, in affect

    self.effect()

  File "eggbot.py", line 314, in effect

    self.EggbotOpenSerial()

  File "eggbot.py", line 1299, in EggbotOpenSerial

    self.serialPort = self.getSerialPort()

  File "eggbot.py", line 1356, in getSerialPort

    for strComPort in eggbot_scan.findEiBotBoards():

  File "D:toolsinkscapeshareextensionseggbot_scanwin32.py", line 6, in findEiBotBoards

    hKey = _winreg.OpenKey( hReg, r"SYSTEMCurrentControlSetEnumUSBVID_04D8&PID_FD92" )

WindowsError: [Error 2] Das System kann die angegebene Datei nicht finden

HMPF

quit Inkscape
replaced the eggbot.py
start inkscape|Eggbot control:

YAY! ok its now repsonding.

BUT: i still hear that motor humming after using the Pen Stepper. Is that normal
“disable Motors” turns it off.

OK, now i need to Home and callibrate it i guess …. i dont find a documentation

Are you using MACOs? Did you try this?: http://forums.jjrobots.com/showthread.php?tid=1168&pid=2386#pid2386


ReplyQuote
fcabb26f497c5b538c07c36dbe0ab626?s=80&d=mm&r=g
(@seananingans)
Member
Joined: 2 weeks ago
Posts: 5
 

@robotn1 I am using macOs, but that link does not work. Is there a new link?


ReplyQuote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 5 years ago
Posts: 722

ReplyQuote
fcabb26f497c5b538c07c36dbe0ab626?s=80&d=mm&r=g
(@seananingans)
Member
Joined: 2 weeks ago
Posts: 5
 

@robotn1 TY!


ReplyQuote
Share: