No connection to th…
 
Share:
Notifications
Clear all

No connection to the Sphere-o-bot – year 2021

Page 1 / 2

a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

The instructions on this forum about connecting are more than 5 years old and definitely obsolete. There is no point to give instructions with ancient program versions. Most of the links are also not working, no wonder, because of the age.

I could not make the portable inkscape work. So, further testing during the weekend. Still no luck. I can connect the sphere-o-bot with arduino programmer, I can flash the code, but I can not connect into it with Inkscape.

Not with the inkscape-sphere-o-bot version and not with Eggbot -page instructions.

 
I have installed now AxiDraw_270r2.exe
and Inkscape 1.0 64bit version
The os is win 10 pro
as instructed on Eggbot page.
 
How can I make Inkscape to see the sphere-o-bot?

Quote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 6 years ago
Posts: 743
 

Use the portable version of the Inskcape: With the eggbot plugin files already installed and configured. Just download it , extract into a folder and launch it. Download it from here 


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

@robotn1 Thanks Been there, done that. Did not work with portable either. It was my first try. Stated also that in the original post.
Thanks anyway.

Jyri


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

Tried this anyway. First I uninstalled Inkscape, then I removed /roaming/inkscape -folder (where the extensions are). Then launched the portable version and got oh-so-familiar Failed to connect to EggBott 🙁 -message. 

Why I was not surprised????

Jyri

 


ReplyQuote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 6 years ago
Posts: 743
 

Can you control the SPHERE-O-BOT via simple commands sent through the SERIAL MONITOR?: https://www.jjrobots.com/community/migrated-forums-4-jjrobots-sphere-o-bot-technical-subforum/having-problems-detecting-the-arduino-checking-things-3/ (select the GENUINO/ARDUINO ZERO BOARD (native USB port)

 

8) From the Arduino IDE, open the SERIAL MONITOR and set its communication parameters as indicated below:

2494=191 Sphere o bot checking hardware

 

[Carriage return, 9600 bauds]
Then, type in the command field: SM,2000,0,-200

This will turn one motor. If you can see it moving, the hardware is OK

 


ReplyQuote
cca803223d280bf1a3ad7b85355e7916?s=80&d=mm&r=g
(@kurtfranzen)
Member
Joined: 5 months ago
Posts: 4
 

Same problem for me.

for point 8) I dont get connection via Arduino IDE

1

 

But I see a connection at devmgmt.

This post was modified 5 months ago by kurtfranzen

ReplyQuote
cca803223d280bf1a3ad7b85355e7916?s=80&d=mm&r=g
(@kurtfranzen)
Member
Joined: 5 months ago
Posts: 4
 

ok. solved the problem.

 

“Open the Device Manager by pressing the Windows Key + R. Type “devmgmt.msc” and press Enter.

  1. Expand the Ports (COM & LPT) section.
  2. Right-click the COM port and select Properties.
  3. Click the Port Settings tab and click Advanced.
  4. Change the COM port number to an available COM port number.

Note: Multiple serial ports cannot share the same COM port number.

  1. Restart your computer.”

 

After switching COM6 to COM2 in Device manager and in Arduino, still was not working with new versions of Inkscape and not with 64 bit. Got Failed to connect to EggBott -message.

But works with Inkscape portable version.

Its Inkscape 0.92.4 version, 32bit, Eggbot 2.4 integrated.


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

Okay, continuing with the issue. Downgraded arduino ide and smd boards to 1.8.10 and flashed the software into the eggbot. Tested the abovementioned turning of the motor => works fine. Set the COM to COM5. Restarted, fired the Inkscape Spherebot -file as an administrator. First test to toggle pen up/down. Got following error:

“The fantastic lxml wrapper for libxml2 is required by inkex.py and therefore this extension.Please download and install the latest version from http://cheeseshop.python.org/pypi/lxml/, or install it through your package manager by a command like: sudo apt-get install python-lxml

Technical details:
No module named lxml”


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

Answering to myself: found in computer’s system variables python path variable. Removed it and got this almost working. I can now rotate the motors in the extension, I can toggle the raise pen ONCE. It lowers the pen and won’t lift it up anymore. The pen rises ONLY at next power on. And can again be toggled down through software.


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

I can toggle the pen in arduino with TP => goes both up and down.

Win10pro 20H2.

 


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

The inkbot extension lowers the servo more than the TP command in Arduino. 


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

So I tweaked and somehow managed  to get it print, but the up-down speed of pen is not settable in inkscape. and tp still not working

 


ReplyQuote
a671ab9fc2a4491b84dd38d8028d6b13?s=80&d=mm&r=g
(@saastamo)
Member
Joined: 5 months ago
Posts: 15
Topic starter  

Looked at the code. It seems that pen raise/lower speed is ignored in the sphere bot firmware. I think that it would be good addition, because it makes the pen movements less violent and gives “slack” to use greater tolerance in pen up – pen low -settings. Now they have to be quite precise, because the speed comes in bigger movemets so big that the servo throws pen arm pointing to stars.

 


ReplyQuote
fcabb26f497c5b538c07c36dbe0ab626?s=80&d=mm&r=g
(@seananingans)
Member
Joined: 4 months ago
Posts: 5
 

@saastamo Can you explain more about the tweaking you did to get it to work? I’m in a very similar spot as you were. TP works on Adruino Serial Monitor, and Inkscape will only lower it once (and it raises on power on).

 

MacOS Big Sur if that helps future debuggers. 


ReplyQuote
fcabb26f497c5b538c07c36dbe0ab626?s=80&d=mm&r=g
(@seananingans)
Member
Joined: 4 months ago
Posts: 5
 

Also, the Walk Motor Manual Control command only makes a humming for both motors, have to disable motors to get it to stop. 

Raise and Lower Pen Manual Controls only toggle the pen. So if you do one command (say, Lower) over and over again, the servo goes up and down.


ReplyQuote
Page 1 / 2
Share: