Servo and stepmothe…
 
Share:
Notifications
Clear all

Servo and stepmother not working


760599a89991fc0d7e2e6b73d7b383bf?s=80&d=mm&r=g
(@alfred-fischer)
Member Customer
Joined: 2 years ago
Posts: 4
Topic starter  

Hello everybody,

i build an eggbot last year ( using an Arduino Leonardo and the jjRobots electronic brain shield v3.1 ) and everything was fine.
A few days ago i want to do some eggs for easter and i have some troubles.
Motor for the egg is turning correctly, Motor for the pen and servo for lifting the pen is not doing anything. I swapped the driver for the stepmothers, no change. Even a new servo is not moving. The stepmother for the pen is under power and making the standard noise.
How can i find out if the Arduino board or the brain shield is the problem. I already ordered a new Arduino, but i can not find the brain shield v3.1 any more.
Thanks for your help in advance
Fredi


Quote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 6 years ago
Posts: 757
 

It is not easy to narrow down the problem.
Try this: change the stepper motor driver from the EGG motor to the PEN motor and see if it moves. That will tell there is a faulty stepper motor driver. Regarding the servo: Do you have any other servo to try on the sphere-o-bot?
And: check the cables. Swap them too (just in case)


ReplyQuote
760599a89991fc0d7e2e6b73d7b383bf?s=80&d=mm&r=g
(@alfred-fischer)
Member Customer
Joined: 2 years ago
Posts: 4
Topic starter  

It is not easy to narrow down the problem.
Try this: change the stepper motor driver from the EGG motor to the PEN motor and see if it moves. That will tell there is a faulty stepper motor driver. Regarding the servo: Do you have any other servo to try on the sphere-o-bot?
And: check the cables. Swap them too (just in case)

Hello, thanks for your help. I swapped the Stepper driver, no change. I connected a new stepper motor, No change. I also tryed the servo on another robotarm and it worked, also connected a new servo, no change.
Doesnt matter what i do, only the stepper for the egg is turning.
In my opinion the arduino or the Brain shield is faulty. But how to find out. I allready ordered a new arduino, but i can not find the Brain shield Board.
Thanks in advance
Fredi


ReplyQuote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Member Admin
Joined: 6 years ago
Posts: 757
 

It is not easy to narrow down the problem.
Try this: change the stepper motor driver from the EGG motor to the PEN motor and see if it moves. That will tell there is a faulty stepper motor driver. Regarding the servo: Do you have any other servo to try on the sphere-o-bot?
And: check the cables. Swap them too (just in case)

Hello, thanks for your help. I swapped the Stepper driver, no change. I connected a new stepper motor, No change. I also tryed the servo on another robotarm and it worked, also connected a new servo, no change.
Doesnt matter what i do, only the stepper for the egg is turning.
In my opinion the arduino or the Brain shield is faulty. But how to find out. I allready ordered a new arduino, but i can not find the Brain shield Board.
Thanks in advance
Fredi

Yes, I would blame the electronics. The Brain shield has been deprecated but the DEVIA is doing the same job. We expect to have it back in stock within 10 days. In the meantime, if I were you, try with the new Leonardo and see how it goes


ReplyQuote
760599a89991fc0d7e2e6b73d7b383bf?s=80&d=mm&r=g
(@alfred-fischer)
Member Customer
Joined: 2 years ago
Posts: 4
Topic starter  

The new arduino board did not change anything 🙁
So for sure the brain shield is damaged !
Hope be able to get a new one soon


ReplyQuote
760599a89991fc0d7e2e6b73d7b383bf?s=80&d=mm&r=g
(@alfred-fischer)
Member Customer
Joined: 2 years ago
Posts: 4
Topic starter  

With the new Devia Board everything is fine again 🙂


ReplyQuote
Share: