Stepper Drive movem…
 
Share:
Notifications
Clear all

Stepper Drive movements not smooth  

  RSS

575647b112b02466900d9c532556f461?s=80&d=mm&r=g
(@disconizer)
New Member
Joined: 8 months ago
Posts: 3
31/03/2020 8:35 pm  

So I was able to build the sphere o bot assy and let it plot a simple text.
But comparing with all the pictures and videos I found so far my print is not that smooth. The steps are somehow to big and not smooth.

Any advice?


Quote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Honorable Member Admin
Joined: 5 years ago
Posts: 687
01/04/2020 11:18 am  

What stepper motor drivers are you using? A4988?


ReplyQuote
575647b112b02466900d9c532556f461?s=80&d=mm&r=g
(@disconizer)
New Member
Joined: 8 months ago
Posts: 3
01/04/2020 1:13 pm  

I bought a DEVIA Robotics Control Board including 2x A4988 drivers.
BTW one of the two drivers is getting real hot compared to the other one.

I have some DRV8825 drivers, but the stepper won’t move with those.


ReplyQuote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Honorable Member Admin
Joined: 5 years ago
Posts: 687
01/04/2020 11:24 pm  

I bought a DEVIA Robotics Control Board including 2x A4988 drivers.
BTW one of the two drivers is getting real hot compared to the other one.

I have some DRV8825 drivers, but the stepper won’t move with those.

Check if that stepper motor driver has the heatsink touching the metal pins of the module. Looks like there is a short circuit (or there was)


ReplyQuote
575647b112b02466900d9c532556f461?s=80&d=mm&r=g
(@disconizer)
New Member
Joined: 8 months ago
Posts: 3
03/04/2020 6:32 pm  

ok, so it was not about the motor drivers but the power supply. Even it states 12V 3A… I got curious because running just one stepper did work out great.
I changed the power supply to a better one and all works great now.


ReplyQuote
350a26dd49eb55d3494500240423a207?s=80&d=mm&r=g
(@robotn1)
Honorable Member Admin
Joined: 5 years ago
Posts: 687
03/04/2020 9:57 pm  

ok, so it was not about the motor drivers but the power supply. Even it states 12V 3A… I got curious because running just one stepper did work out great.
I changed the power supply to a better one and all works great now.

Could you please send us a photo of the faulty power supply please? (to: info@jjrobots.com) We will send you a replacement asap.


ReplyQuote
dca7fce327e7889677f506fdf223bd29?s=80&d=mm&r=g
(@noahos)
New Member Guest
Joined: 2 months ago
Posts: 1
30/09/2020 1:51 pm  

It think it’s short circuit problem


ReplyQuote
Share: